Purchasing of Messages

Minor incident Front-end Home Page
2026-03-22 13:11 GMT · 2 hours, 50 minutes

Updates

Resolved

Purchasing of credits has now been restored.

March 22, 2026 · 16:01 GMT
Issue

There is a intermittent issue in purchasing of messages.
Not all purchases are failing but some might be.

We apologies for the inconvenience.

March 22, 2026 · 13:11 GMT

← Back