Investigating: Payment Processing Issues

Major incident Front-end Home Page Portal
2026-04-01 09:43 BST · 11 hours, 32 minutes

Updates

Monitoring

Technical teams have successfully restored payment processing functionality on the Voodoo platform. Transactions are now flowing normally.

While service is stable, we remain in a monitoring phase as we perform a thorough investigation into the root cause.

April 1, 2026 · 10:23 BST
Issue

We are currently investigating reports of payment failures on the Voodoo platform.

Customers may encounter errors or timeouts when attempting to complete transactions. Our engineering team is identifying the root cause, and we will provide an update as soon as more information is available.

April 1, 2026 · 09:43 BST

← Back